Merkai requires OS 10.5 or newer

Merkai requires OS 10.5 or newer.

Posted in: Applications