Chapter 4
Object Properties and Organization

Learning Objectives

- Using the AutoCAD Quick Setup Wizard
- Create new Multiline Styles
- Draw, using the MULTILINE command
- Use the Multiline Editing commands
- Create new layers
- Pre-selection of objects
- Controlling Layer Visibility
- Moving objects to a different layer
AutoCAD Certified User Examination Objectives Coverage

This table shows the pages on which the objectives of the Certified User Examination are covered in Chapter 4.

<table>
<thead>
<tr>
<th>Section 1: Introduction to AutoCAD</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use a Wizard</td>
</tr>
<tr>
<td>Zoom Realtime</td>
</tr>
<tr>
<td>Layer Visibility</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Section 2: Creating Basic Drawings</th>
</tr>
</thead>
<tbody>
<tr>
<td>Multiline Style</td>
</tr>
<tr>
<td>Multiline</td>
</tr>
<tr>
<td>Snap to Midpoint</td>
</tr>
<tr>
<td>Snap to Endpoint</td>
</tr>
<tr>
<td>Snap From</td>
</tr>
<tr>
<td>Rectangle</td>
</tr>
<tr>
<td>Ellipse</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Section 3: Manipulating Objects</th>
</tr>
</thead>
<tbody>
<tr>
<td>Multiline Edit</td>
</tr>
<tr>
<td>Open Tee, Multiline</td>
</tr>
<tr>
<td>Moving Objects to a Different Layer</td>
</tr>
<tr>
<td>Match Properties command</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Section 4: Drawing Organization and Inquiry Commands</th>
</tr>
</thead>
<tbody>
<tr>
<td>Layers</td>
</tr>
<tr>
<td>Layers Properties</td>
</tr>
<tr>
<td>Layers Control</td>
</tr>
</tbody>
</table>
Introduction

The CAD database of a design may contain information regarding the hundreds of CAD entities that are used to create the CAD model. One of the advantages of using a CAD system is its ability to organize and manage the database so that the designer can access the information quickly and easily. Typically, CAD entities that are created to describe one feature, function, or process of a design are perceived as related information and therefore are organized into the same group. In AutoCAD, the Layer command is used extensively for this purpose. For example, an architectural drawing typically will show walls, doors, windows, and dimensions. Using layers, we can choose to display or hide sub-systems for clarity; we can also change object properties, such as colors and linetypes, quickly and easily.

In this chapter, we will continue to explore the different construction and editing tools that are available in AutoCAD 2015. We will demonstrate the use of the Limits, Mline, Medit, and Layer commands. As you become proficient with the CAD tools and understand the underlying CAD modeling concepts, you are encouraged to experiment with new ideas in using the CAD tools and develop your own style of using the system.

The Floor Plan Design
Starting Up AutoCAD 2015

1. Select the AutoCAD 2015 option on the Program menu or select the AutoCAD 2015 icon on the Desktop. Once the program is loaded into the memory, the AutoCAD 2015 drawing screen will appear on the screen.

Using the Setup Wizard

1. In the Startup dialog box, select the Use a Wizard option as shown in the figure below.

2. In the Select a Wizard section, pick Quick Setup.

- AutoCAD setup wizards allow us to customize several of the AutoCAD settings depending on the wizard we choose. The Quick Setup wizard sets the units and grid display area. Choices for units include Decimal, Engineering, Architectural, Fractional, and Scientific. We can also specify the width and length of a two-dimensional area to establish the extents of the grid displayed, also known as the limits of the working area.
Drawing Units Setup

1. In the Quick Setup Units option, select **Architectural**.

2. Pick **Next** to continue with the Quick Setup settings.

Reference Area Setup

1. In the Quick Setup Area option, enter **60’** and **40’** for the width and length.

2. The two-dimensional area we set up in the Quick Setup is the drawing limits in AutoCAD.

2. Pick **Finish** to accept the settings and end the Quick Setup wizard.
GRID and SNAP Intervals Setup

1. In the Menu Bar, select:
   [Tools] → [Drafting Settings]

2. In the Drafting Settings dialog box, select the SNAP and GRID tab if it is not the page on top.

3. Change Grid Spacing to 6" for both X and Y directions.

4. Also adjust the Snap Spacing to 6" for both X and Y directions.

5. Turn OFF the Adaptive Grid option. (This switch is used to limit the grid display when zooming.)

6. Pick OK to exit the Drafting Settings dialog box.
Using the ZOOM EXTENTS Command in the Navigation Bar

1. Move the cursor inside the Drawing Area and notice that, although we have set the limits to 40' by 60', the default display is still not adjusted to the new settings.

2. In the Navigation toolbar, select Zoom Extents by clicking the left-mouse-button on the icon as shown. We can also click on the triangle icon to select other Zoom options.

   - The navigation bar is a user interface element that provides quick access to display related tools, such as Zoom, Pan and 3D rotation.

The AutoCAD MULTILINE Command

- The Multiline command in AutoCAD 2015 is used to create multiple parallel lines. This command is very useful for creating designs that contain multiple parallel lines, such as walls for architectural designs and for highway designs in civil engineering. The Multiline command creates a set of parallel lines (up to 16 lines) and all line segments are grouped together to form a single multiline object, which can be modified using Multiline Edit and Explode commands. We will first create a new multiline style for our floor plan design.

1. In the Menu Bar, select:

   [Format] → [Multiline Style]

   - The default AutoCAD multiline style is called STANDARD, and it consists of two elements (two parallel lines) with an offset distance of 1.0 inch.
2. In the Multiline Style dialog box choose New to create a new multiline style.

3. In the New Style Name box, enter Wall as the new multiline style name.

4. Click Continue to create the new style.

5. Enter 5" Wall with line endcaps in the Description box.

6. In the Caps section, switch ON the Start and End boxes to enable Line end-caps as shown in the figure.

> All line elements in the multiline style are defined by an offset from a reference line, the multiline origin.

! Multiline Origin: a reference to all other line elements

Each line element is defined by an offset to the Multiline Origin.
Note that in the Elements section, all the line elements are listed in descending order with respect to their offsets. We will create two line elements representing a six-inch wall (offsetting on both sides of the reference location).

7. In the Elements section, highlight the first element in the list, and change the Offset to 2.5.

8. Pick the second element in the Elements section and change the Offset to -2.5.

9. Choose OK to exit the Element Properties dialog box.

- Notice the Add and Delete options are also available, which allow us to create or remove additional elements.

10. With the Wall style highlighted, click Set Current as shown.

11. Click the OK button to end the Multiline Style command. (Note: The Preview section shows the current WALL style.)

- Note that the Save button will save a multiline style to the library of multiline styles. By default, AutoCAD saves the multiline styles information to a file called acad.mln. The Load button allows users to retrieve multiline styles from a library.
Object Snap Toolbar

1. Move the cursor to the Menu Bar area and choose [Tools] → [Toolbars] → [AutoCAD].

- AutoCAD provides 50+ predefined toolbars for access to frequently used commands, settings, and modes. A checkmark (next to the item) in the list identifies the toolbars that are currently displayed on the screen.

2. Select Object Snap, with the left-mouse-button, to display the Object Snap toolbar on the screen.

- Object Snap is an extremely powerful construction tool available on most CAD systems. During an entity's creation operations, we can snap the cursor to points on objects such as endpoints, midpoints, centers, and intersections. For example, we can turn on Object Snap and quickly draw a line to the center of a circle, the midpoint of a line segment, or the intersection of two lines.

3. In the previous chapter, we used several of the object snap options to quickly locate positions on existing geometry. In this chapter we will look at the Snap From option, which is the second icon in the Object Snap toolbar.

- The Snap From option allows us to locate a position using a relative coordinate system with respect to a selected position.

4. In the Status Bar area, reset the option buttons so that GRID DISPLAY, SNAP MODE, ORTHO, and DYNAMIC INPUT are switched ON.


1. Select the **Multiline** command icon in the *Draw* pull-down menu, through the *Menu Bar*, as shown. In the command prompt area, the current settings, such as "Justification = Top, Scale = 1.00, Style = Wall" are displayed.

2. On your own, confirm the **Scale** is set to **1.00**, the **Styles** to **Wall** and the **Justification** to **Top**, by using the **right-mouse-button** to bring up the option list. Change the scale to 1.00 if necessary.

3. In the command prompt area, the message "Specify start point or [Justification/Scale/Style]." is displayed. Select a location near the bottom center of the *Drawing Area* as the **start point** of the multiline.

4. Create a horizontal line by using the **Dynamic Input** option or the **relative rectangular coordinates entry method** in the command prompt area:

   *Specify next point: @-11'6",0 [ENTER]*
5. Create a vertical line by using the Dynamic Input option or the relative rectangular coordinates entry method in the command prompt area:

   Specify next point: @25'6"<90 [ENTER]

6. Create a horizontal line by using the Direct Input option; move the cursor to the right and enter the distance:
   Specify next point: 25'11" [ENTER]

7. Inside the Drawing Area, right-mouse-click and select Enter to end the Multiline command.

8. Hit the spacebar once to repeat the last command, the Multiline command. In the command prompt area, the current settings "Justification = Top, Scale = 1.00, Style = Wall" are displayed.

9. We will use the Snap From option to continue creating the exterior walls. In the Object Snap toolbar, pick Snap From. In the command prompt area, the message "from Base point" is displayed. AutoCAD now expects us to select a geometric entity on the screen.

10. We will position the starting point relative to the last position of the previous multiline. To assure the selection of the endpoint, choose the Snap to Endpoint option as shown.

11. Pick the upper corner of the top horizontal multiline as shown.

  ➢ Note that it is feasible to stack snap options for precise positioning of geometry.
12. The position of the starting point of the new multiline segments is 3' to the right of the reference point we just picked. At the command prompt, enter @3',0" [ENTER].

13. Now enter @1'1",0, to define the top corner of the exterior wall.

14. On your own, complete the multiline segments by specifying the rest of the corners using the dimensions as shown in the figure below.

- Note that the points we specified are defining the outside corners of the floor plan design.

15. Inside the Drawing Area, right-mouse-click and select Enter to end the Multiline command.
Creating Interior Walls

1. Select the Multiline command in the Draw Menu Bar as shown. In the command prompt area, the current settings “Justification = Top, Scale = 1.00, Style = Wall” are displayed. In the command prompt area, the message “Specify start point or [Justification/ Scale/Style]:” is displayed.

2. Inside the Drawing Area, right-mouse-click to display the option menu.

3. Pick Justification in the option menu. In the command prompt area, the message “Enter justification type [Top/Zero/Bottom] <Top>.” is displayed.

4. Inside the Drawing Area, right-mouse-click to display the option menu and select Bottom so that the points we select will be set as alignments for the bottom element.

5. In the Object Snap toolbar, pick Snap to Midpoint. In the command prompt area, the message “_mid of” is displayed. AutoCAD now expects us to select a geometric entity on the screen.

6. Select the outside left vertical line as shown.

7. Using the Dynamic Input option, create a 10’ inside wall toward the right.

8. Now enter @0,1’’, to define the vertical stub wall.

9. Inside the Drawing Area, right-mouse-click and select Enter to end the Multiline command.
• Next, we will create a vertical wall right above the last corner.

10. Hit the **spacebar** once to repeat the last command, the **Multiline** command. Since the last position used is directly below the new location, we will just enter the relative coordinates. At the command prompt, enter **@0,2'8" [ENTER]**.

11. Place the other end above the top horizontal line as shown in the figure below. In the next section, we will use the **Multiline Edit** tools to adjust these constructions.

12. Inside the Drawing Area, right-mouse-click and select **Enter** to end the Multiline command.

13. Hit the **spacebar** once to repeat the last command, the **Multiline** command. In the text window, the current settings “**Justification = Bottom, Scale = 1.00, Style = Wall**” are displayed. In the command prompt area, the message “**Specify start point or [Justification/Scale/Style] :**” is displayed.

14. Inside the **Drawing Area**, **right-mouse-click** to display the option menu.

15. Pick **Justification** in the option menu. In the command prompt area, the message “**Enter justification type [Top/Zero/Bottom] <Bottom> :**” is displayed.

16. Inside the **Drawing Area**, **right-mouse-click** to display the option menu and select **Top** so that the points we select will align to the top element.
17. In the Object Snap toolbar, pick **Snap From**. In the command prompt area, the message "from Base point" is displayed. AutoCAD now expects us to select a geometric entity on the screen.

18. In the Object Snap toolbar, pick **Snap to Endpoint**. In the command prompt area, the message "endp of" is displayed.

19. We will create another inside wall on the right side. Pick the corner as shown.

20. At the command prompt, enter @28",0 [ENTER].

21. Pick a location that it to the right of the right-vertical exterior wall. The drawing should appear as shown in the figure below.

> One of the main advantages of using a CAD system to create drawings is the ability to create and/or modify geometric entities quickly, using many of the available tools. Unlike traditional board drafting, where typically only the necessary entities are created, CAD provides a much more flexible environment that requires a slightly different way of thinking, as well as taking a different view of the tasks at hand.
Joining the Walls Using **MULTILINE EDIT**

1. In the Menu Bar, select: [Modify] \(\rightarrow\) [Object] \(\rightarrow\) [Multiline]

   ![Multiline Edit Tools](image)

   - The Multiline Edit Tools dialog box appears. Select the **Help** button to see the description of the available Multiline Edit Tools.

2. Pick the **Open Tee** option in the dialog box.

   - We will need to select two multilines for this option: first, select the multiline to trim or extend; and second, select the intersecting multiline.

3. Pick the **horizontal multiline** as the first object, *multiline to trim*, as shown.

4. Pick the **vertical multiline** as the 2nd object, *intersecting multiline*.

   - The **Open Tee** option automatically trims the lines to form the proper shapes.
5. Repeat the above steps and modify the connection of the other two inside walls.

6. Inside the Drawing Area, right-mouse-click once and select **Enter** to end the Mledit command.

7. Using the **Multiline/MEdit** options, create the additional walls and doorways as shown.

- Now is a good time to save the design. Select **[File] → [Save As]** in the **Menu Bar** and use **FloorPlan** as the **File name**.
Using Layers and Object Properties

In AutoCAD 2015, layers can be thought of as transparent overlays on which we organize different kinds of design information. Typically, CAD entities that are created to describe one feature or function of a design are considered as related information and therefore can be organized into the same group. The objects we organized into the same group will usually have common properties such as colors, linetypes, and lineweights. Color helps us visually distinguish similar elements in our designs. Linetype helps us identify easily the different drafting elements, such as centerlines or hidden lines. Lineweight increases the legibility of an object through width. Consider the floor plan we are currently working on. The floor plan can be placed on one layer, electrical layout on another, and plumbing on a third layer. Organizing layers and the objects on layers makes it easier to manage the information in our designs. Layers can be used as a method to control the visibility of objects. We can temporarily switch ON or OFF any layer to help construction and editing of our designs.

AutoCAD allows us to create an infinite number of layers. In general, twenty to thirty layers are sufficient for most designs. Most companies also require designers and CAD operators to follow the company standards in organizing objects in layers.
1. Pick **Layers Properties** in the **Layers** toolbar as shown.

- The **Layer Properties Manager** dialog box appears. AutoCAD creates a default layer, *layer 0*, which we cannot rename or delete. Note that *Layer 0* has special properties that are used by the system.

- In AutoCAD, we always construct entities on a layer. It may be the default layer or a layer that we create. Each layer has associated properties such as the visibility setting, color, linetype, lineweight, and plot style.

2. Click on the **New Layer** button. Notice a layer is automatically added to the list of layers.

- Note that we can create an unlimited number of layers in a drawing.

3. AutoCAD will assign a generic name to the new layer (*Layer 1*). Enter **BathRoom** as the name of the new layer as shown in the figure below.

- Layer properties can be adjusted by clicking on the icon or name of a property. For example, clicking on the *light-bulb* icon toggles the visibility of the layer *ON* or *OFF*. 
4. Pick the color swatch or the color name (White) of the BathRoom layer. The Select Color dialog box appears.

5. Pick Cyan (Index color: 4) in the Standard Colors section. Notice the current color setting is displayed at the bottom of the dialog box.

6. Click on the OK button to accept the color assignment.

7. Click on the Set Current button to make BathRoom the Current Layer. There can only be one Current Layer, and new entities are automatically placed on the layer that is set to be the Current Layer.

8. Click on the Close button, at the upper left corner of the dialog box, to accept the settings and exit the Layer Properties Manager dialog box.
The Layer Control toolbar in the top of the AutoCAD toolbar panel shows the status of the active layer. The BathRoom layer is shown as the current active layer. Note that this Layer toolbar can also be used to control the settings of individual layers.

Using Zoom Realtime

1. Click on the Zoom Realtime icon in the Navigate toolbar located to the right side of the Drawing Area.

2. Inside the Drawing Area, push and hold down the left-mouse-button, then move upward to enlarge the current display scale factor. (Press the [Esc] key to exit the Zoom command.)

3. Use the Zoom Realtime option to reposition the display so that we can work on the bathroom of the floor plan.

Note that the mouse-wheel can also be used to Zoom Realtime; turning the wheel forward will enlarge the current display scale factor.
Modeling the Bathroom

1. In the Status Bar area, reset the option buttons so that all of the buttons are switched OFF.

2. Click on the Rectangle command icon in the Draw toolbar. In the command prompt area, the message “Specify first corner point:” is displayed.

3. In the Object Snap toolbar, pick Snap to Endpoint. In the command prompt area, the message “_endp of” is displayed. AutoCAD now expects us to select a geometric entity on the screen.

4. Use the Dynamic Input options and create the outer rectangle of the tub (2'-6" x 5'-10").

5. Complete the inner shape by creating a rectangle with a distance of 3" from the outer rectangle and rounded corners of 3" radius.
6. Create two rectangles (10" × 20" and 20" × 30") with rounded corners (radius 3") and position them as shown.

7. Select the **Ellipse → Axis, End** command icon in the *Draw* toolbar. In the command prompt area, the message “Specify axis endpoint of ellipse or [Arc/Center]:” is displayed.

8. In the *Object Snap* toolbar, pick **Snap to Midpoint**. In the command prompt area, the message “_mid of” is displayed.

9. Pick the *top horizontal line* of the small rectangle we just created.

10. For the second point location, enter **@0,20”**[ENTER].

11. For the third point, enter **@7.5”,0** [ENTER].

- An ellipse has a major axis, the longest distance between two points on the ellipse, and a minor axis, the shorter distance across the ellipse. The three points we specified identify the two axes.
Controlling Layer Visibility

AutoCAD does not display or plot the objects that are on invisible layers. To make layers invisible, we can freeze or turn off those layers. Turning off layers only temporarily removes the objects from the screen; the objects remain active in the CAD database. Freezing layers will make the objects invisible and also disable the objects in the CAD database. Freezing layers will improve object selection performance and reduce regeneration time for complex designs. When we thaw a frozen layer, AutoCAD updates the CAD database with the screen coordinates for all objects in the design.

1. On the Layers toolbar panel, choose the triangle next to the Layer Control box with a click of the left-mouse-button.

2. Move the cursor over the light-bulb icon for layer 0. The tool tip “Turn a layer On or Off” appears.

3. Left-mouse-click once and notice the icon color is changed to a dark color, representing the layer (Layer 0) is turned OFF.

4. Move the cursor into the Drawing Area and left-mouse-click once to accept the layer control settings.

➢ On your own, practice turning on Layer 0 and freezing/thawing Layer 0. What would happen if we turn off all layers?

Adding a New Layer

1. Pick Layer Properties Manager in the Layers toolbar panel. The Layer Properties Manager dialog box appears.

2. Create a new layer (layer name: Walls) and change the layer color to Green.

3. Turn ON the 0 layer, turn OFF the BathRoom layer, and set the Walls layer as the Current Layer. Click on the Close button to exit Layer Properties.

[Diagram and table showing layer properties]
Moving Objects to a Different Layer

AutoCAD 2015 provides a flexible graphical user interface that allows users to select graphical entities BEFORE the command is selected (pre-selection), or AFTER the command is selected (post-selection). The procedure we have used so far is the post-selection option. We can pre-select one or more objects by clicking on the objects at the command prompt (Command:). To deselect the selected items, press the [Esc] key twice.

1. Inside the Drawing Area, pre-select all objects by enclosing all objects inside a selection window as shown.

2. On the Object Properties toolbar, choose the Layer Control box with the left-mouse-button.

   - Notice the layer name displayed in the Layer Control box is the selected object's assigned layer and layer properties.

3. On your own, switch the Walls layer on and off to confirm the setup.

4. Before continuing to the next page, switch ON both Walls and Bathroom layers.
Matching Layer Properties

1. Pick **Match** in the *Layer control* toolbar panel. In the command prompt area, the message "Select objects to be changed:" is displayed.

2. Select the **bathtub** using a selection window as shown.

3. Inside the Drawing Area, **right-mouse-click** once to accept the selection.

4. Select one of the **Walls** as the object properties to match.

   In the *command prompt area*, notice the selected objects have been moved to the Walls layer.

5. On your own, switch **on** and **off** of the **Walls and bathroom** layers to examine the results of the *Match Layer Properties* command.
On your own, complete the floor plan by creating the 4' and 5' windows in a new layer *Windows*. The dimensions are as shown in the figure below.
Review Questions: (Time: 25 minutes)

1. List some of the advantages of using layers.

2. List two methods to control the layer visibility in AutoCAD 2015.

3. Describe the procedure to move objects from one layer to another.

4. When and why should you use the Multiline command?

5. Is there a limitation to how many layers we can set up in AutoCAD?

6. List and describe the two options available in AutoCAD to create ellipses.

7. Is there a limitation to how many parallel lines we can set up when using AutoCAD Multiline objects?

8. What is the name of the layer that AutoCAD creates as the default layer (the layer that we cannot rename or delete)?

9. When and why would you use the Match Properties command?

10. A chamfer connects two objects with an angled line. A chamfer is usually used to represent a beveled edge on a corner. Construct the following corners by using the Chamfer command.

11. List the commands you would use to create the following multilines in a drawing.
Exercises: (Time: 120 minutes)

1. **Floor Plan A** (Wall thickness: 5 inch)
2. Floor Plan B (Wall thickness: 5 inch)
Notes: